Root > Compatibility > 3.x -> 4.x

3.x -> 4.x

Previous pageReturn to chapter overviewNext page   

Please read the following instructions if you wish to install EurekaLog 4.x as an upgrade from EurekaLog 3.x:

 

1.Check the new "Exception Log Options". Some of the old options are no longer available. Save your old options before continuing.
2.Replace the old "ExceptionHandle.OnException" event with the new ExceptionNotify event.
3.Don't use the "TEurekaThread.EurekaHandleException" method for managing thread exceptions. EurekaLog now has fully-automatic support for multithreaded applications.
4.Change all references to the ExceptionLog2 unit to ExceptionLog. The ExceptionLog2 unit was used in the old version for managing Console applications.

 

That's all.

 

 

See also:




Send feedback... Build date: 2021-11-08
Last edited: 2018-06-14
PRIVACY STATEMENT
The documentation team uses the feedback submitted to improve the EurekaLog documentation. We do not use your e-mail address for any other purpose. We will remove your e-mail address from our system after the issue you are reporting has been resolved. While we are working to resolve this issue, we may send you an e-mail message to request more information about your feedback. After the issues have been addressed, we may send you an email message to let you know that your feedback has been addressed.


Permanent link to this article: https://www.eurekalog.com/help/eurekalog/old_3_x_version.php