Root > How to... > ...add EurekaLog to a project? > ...remove EurekaLog from the project?

...remove EurekaLog from the project?

Previous pageReturn to chapter overviewNext page   

If you want to completely remove EurekaLog from the project - go to IDE's "Project" / "EurekaLog Options" menu:

 

 

EurekaLog project options in IDE menu

 

Don't see EurekaLog menu items?

 

Then click on the "Reset" button:

 

 

Reset button in the EurekaLog's options dialog

 

EurekaLog will ask you if you want to completely remove EurekaLog from the project (e.g. with deleting EurekaLog's options) or just disable it:

 

 

Confirmation dialog

 

Click on the "Remove EurekaLog" button.

 

This will delete EurekaLog's settings from the project, so EurekaLog will no longer be compiled in.

 


 

However, if you have added or wrote any EurekaLog's code in your application manually - you must remove it too (unless you've done it correctly). While removing EurekaLog-specific code - do not forget to remove EurekaLog's units from uses clauses. Our unit names starts with 'E', for example: EBase, EDebugInfo, ExceptionLog7, etc.

 

Important: a typical mistake is forgetting to remove the TEurekaLogEvents component from the form as well as forgetting to remove EComponent unit from the same form.

 

If you are unable to find which of your units still references EurekaLog's units - do the following:

1. Close your IDE;
2. Go to "Start" / "Programs" / "EurekaLog" / "Manage EurekaLog in IDEs";
3. Click on your IDE in the shown dialog;
4. Click on "Unregister EurekaLog";
5. Run your IDE;
6. Open your project;
7. Use "Project" / "Build Project" (not "Compile", not "Make");
8. If any of your units contains reference to EurekaLog's units - IDE/compiler will complain, so you can easily spot this and remove;
9. Once you have fixed the problem - close your IDE and return to step 3;
10. Click on "Register EurekaLog (recommended)" in the "Manage" tool.

 

 

See also:




Send feedback... Build date: 2022-03-28
Last edited: 2022-01-14
PRIVACY STATEMENT
The documentation team uses the feedback submitted to improve the EurekaLog documentation. We do not use your e-mail address for any other purpose. We will remove your e-mail address from our system after the issue you are reporting has been resolved. While we are working to resolve this issue, we may send you an e-mail message to request more information about your feedback. After the issues have been addressed, we may send you an email message to let you know that your feedback has been addressed.


Permanent link to this article: https://www.eurekalog.com/help/eurekalog/how_to_remove_eurekalog.php