Root > Troubleshooting > Enabling EurekaLog problems

Enabling EurekaLog problems

Previous pageReturn to chapter overviewNext page   

When you have enabled EurekaLog for your project - you must build your project:

 

 

Build your project

 

You will see a standard processing window, where you can see "Compiling" and "Linking" stages.

 

See also: Compiling your project with EurekaLog.

 

You should see one additional stage at the very end of this process. This stage is called "post-processing". "EurekaLog":

 

 

EurekaLog's post-processing during compilation

Note "EurekaLog" stage

 

It indicates that EurekaLog is active, enabled and doing post-processing of your executable.

 

Additionally, EurekaLog's post-processing stage will be listed in IDE compiler output - use IDE's "View" / "Messages" command to open it:

 

 

"EurekaLog" / "post-processing" stage in IDE output

 

 

Same window expanded - this is output from a normal successful compilation

 

If you don't see this post-processing stage and/or IDE messages output is empty - then something is wrong.

 

 

Most common problems

1. You have dropped TEurekaLogEvents component on the form but did not enabled EurekaLog for your project via "Project" / "EurekaLog Options" menu. TEurekaLogEvents component is supposed to react on EurekaLog's events, but it does nothing if EurekaLog is not added. Please, enable EurekaLog for your project as explained here.

 

2. You have enabled EurekaLog for your project, but disabled EurekaLog for currently active profile. Enabling EurekaLog for a particular build configuration is essentially the same as defining EUREKALOG conditional symbol for this configuration. You can change that either via EurekaLog's project options dialog:

 

 

EurekaLog must be enabled either for "Base" or for your profile

 

or by editing project options manually:

 

 

"EUREKALOG" conditional symbol must be defined

 

3. If you don't see any output from EurekaLog at all, but you are 100% sure that EurekaLog is installed and configured - then this usually means that EurekaLog is unable to locate output compiled file. From EurekaLog's perspective - this means that compilation has failed and did not produce any file.

 

However, if compilation was successful, and EurekaLog still can't find output file - then something is wrong. For example, check if your .dpr file has any IFDEFs that may modify project's type (e.g. program/library/package keywords). EurekaLog uses a very simple source code parser, which is unable to follow conditionals, so EurekaLog may be confused about actual content of your project. Check that your conditions does not hide or duplicate uses clause.

 

There may be other possible reasons. For example, bugs in RAD Studio's OTA (OpenTools API) sometimes return invalid results (wrong file paths or extensions). We have several workarounds to detect such cases, but may be you have found a new bug. This is especially true if you compile several projects or using build groups.

 


 

Make sure that:

 

1. EurekaLog IDE expert is installed:

 

 

Verifying that EurekaLog IDE expert is installed

 

You should find it into "Components" \ "Install packages" IDE menu. If EurekaLog IDE Expert package is disabled - enable it. If it's not even there - click on "Add" button and pick EurekaLogExpert.bpl package from \Packages\IDEName\ subfolder of your EurekaLog installation. Replace IDEName with your real IDE version. Use IDE name mapping to determinate which folder corresponds to your IDE.

 

If you can't find EurekaLogExpert.bpl file - then you need to reinstall EurekaLog and make sure that you have selected support for your IDE during installation. Please, follow these guidelines.

 

 

2. EurekaLog is enabled in your project:

 

 

Enabling EurekaLog in your project

 

Please, follow these guidelines. Make sure to apply proper application type for your project!

 

 

3. Project has appropriate settings:

 

 

Generation of .map files has to be turned ON

 

 

"EUREKALOG" conditional symbol must be defined

 

4. Finally, ensure that EurekaLog is post-processing your executable:

 

 

Sample output from a normal successful compilation

 

If you don't see any output from EurekaLog at all, but you are 100% sure that EurekaLog is installed and configured - then this usually means that EurekaLog is unable to locate output compiled file. From EurekaLog's perspective - this means that compilation has failed and did not produce any file.

 

However, if compilation was successful, and EurekaLog still can't find output file - then something is wrong. For example, check if your .dpr file has any IFDEFs that may modify project's type (e.g. program/library/package keywords). EurekaLog uses a very simple source code parser, which is unable to follow conditionals, so EurekaLog may be confused about actual content of your project. Check that your conditions does not hide or duplicate uses clause.

 

There may be other possible reasons. For example, bugs in RAD Studio's OTA (OpenTools API) sometimes return invalid results (wrong file paths or extensions). We have several workarounds to detect such cases, but may be you have found a new bug. This is especially true if you compile several projects or using build groups.

 


 

Once you've checked and verified the above mentioned items - make final confirm that EurekaLog was really injected into your executable:

 

 

Typical output from Module Informer for correct compiled file

Note "Is EurekaLog image: True"

 


 

However, if EurekaLog is installed, but you don't see any actions from it - create a run-time log. First, close your IDE, and edit shortcut's properties (.lnk): add "--el_debug" command-line switch to your IDE:

 

 

Enabling debug mode for IDE

 

Run your IDE and perform all steps as usual (e.g. project setup, compilation, etc.). Close your IDE.

 

Look for el_debug.csl file in %APPDATA%\Neos Eureka S.r.l\EurekaLog\Bug Reports\bds.exe\el_debug.csl folder (it can also be found in \bin folder of your IDE, when IDE has permissions to write to this folder). Send us this .csl file for analyzing (please, pack it inside any type of archive).

 

 

See also:




Send feedback... Build date: 2020-10-22
Last edited: 2019-10-25
PRIVACY STATEMENT
The documentation team uses the feedback submitted to improve the EurekaLog documentation. We do not use your e-mail address for any other purpose. We will remove your e-mail address from our system after the issue you are reporting has been resolved. While we are working to resolve this issue, we may send you an e-mail message to request more information about your feedback. After the issues have been addressed, we may send you an email message to let you know that your feedback has been addressed.


Permanent link to this article: https://www.eurekalog.com/help/eurekalog/enabling_eurekalog_problems.php